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ВСТУП

Швидкий розвиток обчислювальної техніки і її впровадження практично в
усі сфери життя привело до того, що сьогодні грамотний фахівець в будь-якій
області знань повинен добре орієнтуватися в світі комп'ютерів і володіти необ-
хідними програмними засобами. Сучасний інженер неможливий без знання си-
стем автоматичного проектування (CAD - Computer Aids Design), автоматично-
го виробництва (CAM - Computer Aids Manufacturing) і автоматичного інженер-
ного аналізу (CAE - Computer Aids Engineering). Такі CAD/CAM системи як
AutoCAD, DUCT, Pro/Engineer, Unigraphics і SolidsWorks широко використову-
ються для комп'ютерного моделювання виробів складної форми, з подальшим
випуском креслень і генерацією керуючих програм для верстатів з ЧПУ.

Одним з найпоширеніших таких комплексів сьогодні є програма ANSYS,
що використовує метод кінцевих елементів.

Особливістю програми є файлова сумісність всіх членів сімейства ANSYS
для всіх використовуваних платформ. Багатоцільова спрямованість програми
дозволяє використовувати одну й ту ж модель для вирішення різних пов'язаних
завдань. Програма ANSYS є засобом, за допомогою якого створюється комп'ю-
терна модель або обробляється CAD-модель конструкції; прикладаються діючі
зусилля; досліджується відгуки системи різної фізичної природи у вигляді роз-
поділів напружень і температур, електромагнітних полів. Все це допомагає ско-
ротити цикл розробки, що складається у виготовленні зразків - прототипів, їх
випробувань і повторному виготовленні зразків, а також виключити дорогий
процес доопрацювання виробів.
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АНАЛІЗ РОЗПОДІЛЕНОГО НАВАНТАЖЕННЯ НА
НАПУЖЕНО-ДЕФОРМОВАНИЙ СТАН БАЛКИ

Мета роботи: Моделювання напружено-деформованого стану балки,
яка навантажена розподіленим по всій довжині навантаженням з використан-
ням типу аналізу Static Structural – аналізу статичної міцності в
AnsysWorkbench.

Сталева горизонтально розташована балка з шарнірним обпиранням на
торцях розмірами 40×40×1000 мм навантажена розподіленим вертикальним на-
вантаженням F=5000Н/м.

Загальний вигляд моделі представлений на рис. 1.

Рис. 1. Загальний вигляд моделі.

Методика виконання завдання

Увага! По ходу виконання проекту для формування звіту потрібно зберігати у
файлах копії поточних рисунків .

1. Підготовка проекту.
1.1. Підготовка робочої директорії (папки) для зберігання файлів завдан-

ня 7 (наприклад, на диску F:\LabANSYS_8);
1.2. Запуск Workbеnch. Створення нового проекту: вказати робочу дирек-

торію та унікальне ім’я файлам.

Пуск → Програми → AnsysWorkbench → Save as

Завантажена платформа має головне меню, панель інструментів (Toolbox)
та схему проектів (Project Schematic) .

1.3. Вибрати систему одиниць виміру – систему СІ.
Main menu → Units → Metric

1.4. Вибір типу аналізу.

Toolbox → Analysis system → structural

В даній роботі вибираємо аналіз статичної міцності конструкції. При
цьому в полі вікна схеми проектів активізується меню даного проекту, яке
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включає такі позиції:
• Engineering Data – підпрограма вибору механічних властивостей мате-

ріалу;
• Geometry – підпрограма побудови геометричної моделі;
• Model – підпрограма побудови СЕ-сітки та вибору граничних умов;
• Setup and Solution – завдання опцій для процедур розрахунку;
• Results – візуалізація отриманих результатів.

2. Задавання механічних характеристик

або клік правою кнопкою миші по позиції Edit у вспливаючому вікні

Активізуються декілька вікон:
• в першому – бібліотека матеріалів;
• в другому – вибір характеристик конкретного матеріалу;
• в третьому – перегляд заданих у бібліотеці властивостей для обраного

матеріалу.
Виберемо в бібліотеці матеріал Structural Steel («Конструкційна сталь»).

Рис. 2. Вибір матеріалу в бібліотеці.

Зауваження: якщо вікно аналізу Engineering Data приховане, то:

Main menu → View → Reset → Workspace

Повернення до меню проекту:

Main menu → Return to Project
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3. Побудова геометричної моделі.
3.1. Активізація вікна підпрограми Design Modeler, в якому відбувається

побудова геометричної моделі:

кнопкою миші по опції New geomentry у вспливаючому вікні

3.2. У вкладці вибрати розміри в мм.
Main menu → Units

Design Modeler включає:
• Main Menu – головне меню;
• Tree Outline – дерево геометричної моделі;
• Graphics – вікно виводу графіки.
Головним засобом побудови геометричних моделей є використання ескі-

зів (Sketchs).
3.3. Розглянемо побудову ескізу балки.
3.3.1. У дереві моделі TreeOutline за робочу площину виберемо ХYPlane.
3.3.2. Створюємо новий ескіз Sketch1:

Main menu → Newsketch

Для зручності зображення вертикальних і горизонтальних ліній включи-
мо відображення допоміжної сітки за допомогою панелі Sketching Toolboxes-
Settings, встановивши галочку навпроти Grid-Show in 2D

3.3.3. Активізуємо Sketch1 та задаємо для нього ХYPlane як проекцію при
побудові зображення:

Main menu → Treeoutline → Sketch1 (клік правою кнопкою миші) → Look at face

3.3.4. Побудова прямокутника із розмірами, що задані в вихідних даних:

Main menu → Treeoutline → Sketching → Draw → Recnangle

3.3.5. Виставляємо виноски розмірів:

Sketching → Dimensions → General → виносимо стрілки розмірностей

Їх точні значення проставляємо у вікні Details View.
3.3.6. На панелі меню вибираємо кнопку Extrude (рис. 4) для видовження по-

будованого ескізу перерізу балки, а у вікні Details View задаємо її точну довжину.
Лінійне видавлювання Extrude дозволяє отримати об’єм за рахунок пря-

молінійного зміщення обраного ескізу на деяку відстань в заданому напрямку.
Base Object – ім’я ескізу, використовуваного для побудови об’єму.

Operation – вид операції видавлювання, який вказує особливості побудови
об’єму. За умовчанням вибрано Add Material, що означає заповнення одержу-
ваного об’єму (суцільне тіло). Якщо у вікні побудови вже є інші тіла, то цей па-
раметр може мати значення Cut Material – видалення матеріалу в одержувано-
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му об’ємі, або Imprint Faces – отримувана поверхня «карбується» в об’ємні ті-
ла, через які вона проходить. Значення Add Frozen дозволяє створити зафіксо-
ване тіло.

Direction Vector – лінія, що задає напрямок видавлювання. Для завдання
цього параметра необхідно вибрати у вікні моделі відрізок, ребро або коорди-
натну вісь. За замовчуванням задане None Normal, що означає видавлювання по
нормалі до площини ескізу.

Рис. 3. Форма вікна Graphics після проведених операцій

Direction – напрямок вздовж лінії видавлювання. Даний параметр може
приймати такі значення: Normal – у напрямку від початкової точки до кінцевої для
лінії видавлювання, Reversed – протилежний напрямок, Both Symmetriс – видав-
лювання в обох напрямках на однакову відстань, Both Asymmetric – видавлювання
в обох напрямках на різні відстані.

Extent Туре – тип видавлювання. За замовчуванням задане Fixed – видав-
лювання на фіксовану відстань, але також може бути Through All – видавлювання
через всі поверхні, Тo Next – видавлювання до найближчої поверхні, То Face –
видавлювання до вказаної межі тіла без зміни поверхні контакту, То Surface – ви-
давлювання до вказаної межі тіла з відповідною зміною поверхні контакту.

Рис. 4.  Операція Extrude
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3.3.7. Generate – фіксуємо всі зміни при побудові частини моделі. Одер-
жуємо тривимірну суцільну заготовку для балки (рис. 5).

Рис. 5. Балка

3.3.8. Масштабування, пересування зображення, відміну операції можна
здійснити з допомогою різних опцій меню, як то:

Main menu → Rotate/Pan/Zoom/UnDo та інші.

3.3.9. Закриваємо програму Desing Modeler та повертаємось до схеми
проекту (Project Schematic).

4. Cтворення СЕ-сітки.
4.1. Активізація вікна підпрограми Mechanical.

або правою кнопкою миші по опції Edit

Подальша робота відбувається в цьому вікні, яке має Головне меню (Main
Menu), дерево моделі (Outline), вікно параметрів (Details of …) та вікно виводу
графіки (Geometry). Дерево моделі надає доступ до всіх параметрів: геометрії,
матеріалу, системи координат, СЕ, граничних умов та чисельного алгоритму.

4.2. Визначаємо розміри елементу СЕ-сітки

Mesh → Details of mesh → Element size → 20mm (рис. 6)

Outline → Mesh → Generate mesh

4.3. Або можна виконати тільки автоматичну побудову СЕ-сітки:

Outline → Mesh → Generate mesh

4.4. Для завдання граничних умов обираємо

Outline → Structural (А5)
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З’являються пункти завдання граничних умов: Inertia («Сили інерції»),
Loads («Навантаження»), Supports («Обмеження»).

Рис. 6. Створення сітки

4.5. Задаємо варіант закріплення лівого краю балки (рис. 7):

Details of Fixed supports → Apply

Рис. 7. Завдання граничних умов

4.6. Задаємо варіант закріплення правого краю балки (рис. 8):

Details of Displaysmants → Apply

Details of Displaysmants → Constant → Y=0, X=0 → Z-Free → Apply
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Рис. 8. Варіант закріплення правого краю балки

4.7. Для завдання розподіленого навантаження необхідно обрати (рис. 9):

Вибір напрямку прикладання та величини навантаження:

Details of Displaysmants → → Apply

Рис. 9. Завдання розподіленого навантаження

Модель готова до розрахунків.
4.8. Вибір параметрів розрахунку:

Outline → (A6) → Insert

З’являються пункти параметрів розрахунку: Deformation («Переміщен-
ня»), Stress («Напруження») та інші. Обираємо Directionаl Deformations «Сума-
рні переміщення» (рис. 10):



11

Outline → (A6) → Insert → аl

На панели

Details of Directionаl Deformations → → Y Axsis

Обираємо еквівалентні напруження за Мізесом (рис. 11):

(A6)→ Insert → Stress → Equivalent (von-Mises)

Рис. 10. Вибір параметрів розрахунку (переміщення)
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Рис. 11. Вибір параметрів розрахунку (напруження)

4.9. Solve – запустити вирішення
Результат обчислень наведено на рис.28-29.
Для того щоб подивитись розподіл напружень за перерізом, на панелі

треба обрати Section plane та позначити місце перерізу (рис. 12).

Рис. 12. Позначення місця перерізу

Результат обчислень наведено на рис.30
Для побудови епюри обираємо:

Model → Insert → Geometry → Insert → Path → обрати грань
початку → Coordinate → Apply → обрати грань кінця →

End → Apply (рис. 13 – 15)
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Рис. 13.

Рис. 14.

Рис. 15.
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Для побудови лінії деформації необхідно обрати:

Path → (A6) → (рис. 16)

Рис. 16

На панелі Details of Directionаl Deformation2

(рис. 17)

Рис. 17
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(рис. 18)

Рис. 18.

Solution(A6) → (рис. 19)

Рис. 19

Результат обчислень наведено на (рис.31). Для отримання епюри напру-
жень обираємо:

(рис. 20)
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Рис. 20

Details of Equivalent stress 2 → Scoping Method → Path (рис. 21)

Рис. 21

Details of Equivalent stress 2 → Path → Path (рис. 22)

Рис. 22

(рис. 23)
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Рис. 23

Результат обчислень наведено на (рис.32). Для визначення нормальних
напружень обираємо:

Outline → n (A6) → Insert → Stress → Normal (рис. 24)

Рис. 24

Details of Normal stress → → ZAxis (рис. 25)

Рис. 25



18

Outline → → Normal stress → Evaluate All Results (рис. 26)

Рис. 26

В результаті розрахунків маємо розподіл нормальних напружень (рис.33).
4.10. Save – зберігання готового проекту.
По ходу виконання проекту для формування звіту потрібно зберігати у

файлах копії поточних рисунків. Це можна зробити двома способами. Або
Image та зберегти зображення, або Figure та найменування відповідних опера-
цій (рис. 27).

Рис. 27. Збереження копій поточних рисунків

Результати розрахунків
На рис. 28 - 33 наведений розподіл параметрів напружено-деформованого

стану в сталевій балці, яка навантажена постійним розподіленим навантажен-
ням.

Рис. 28. Деформації в напрямку осі Y



19

Рис. 29. Еквівалентні напруження

Рис. 30. Еквівалентні напруження в перерізі.

Рис. 31. Епюра деформацій
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Рис. 32. Епюра еквівалентних напружень

Рис. 33. Епюра нормальних напружень

Контрольні питання:
1. Послідовність яких команд визначає завдання матеріалу в проекті?
2. Що таке граничні умови?
3. За допомогою яких команд можна налаштувати СЕМ в програмному

середовищі Ansys Workbench?
4. Пояснити, що таке напруження, деформація, закон Гука, Е та яким чи-

ном ці характеристики задаються для конкретного матеріалу?
5. Яка команда запускає на розрахунок всі завдання?
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