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ВСТУП 

Математична теорія нечітких множин (fuzzy sets) і нечітка 

логіка (fuzzy logic) є узагальненнями класичної теорії множин і 

класичної формальної логіки. Дані поняття були вперше 

запропоновані американським вченим Лотфі Заде (Lotfi Zadeh) в 1965 

р. Основною причиною появи нової теорії стало наявність нечітких і 

наближених міркувань при описі людиною процесів, систем, об'єктів. 

Сама ж нечітка логіка виникла як найбільш зручний спосіб побудови 

систем керування метрополітенами і складними технологічними 

процесами, а також знайшла застосування в побутовій електроніці, 

діагностичних та інших експертних системах. 

У зв'язку з цим для реалізації процесу нечіткого моделювання в 

середовищі MATLAB був розроблений спеціальний пакет 

розширення Fuzzy Logic Toolbox, в рамках якого користувач може 

виконувати необхідні дії по розробці і використанню нечітких 

моделей в одному з наступних режимів: 

- в інтерактивному режимі, за допомогою графічних засобів 

редагування і візуалізації всіх компонентів систем нечіткого виводу; 

- в режимі команд, за допомогою введення імен відповідних 

функцій з необхідними аргументами безпосередньо у вікно команд 

системи MATLAB. 

Основною метою даного методичного вказівки є вивчення 

основних понять теорії нечітких множин та їх додатків, а також 

знайомство з пакетом математичних додатків MATLAB. 
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Практична робота №1 

«Керування температурою і вологість повітря в теплиці» 

 

Мета: Ознайомлення зі складом і можливостями 

інструментарію нечіткої логіки Fuzzy Logic Toolbox, що входить в 

пакет програм MATLAB. 

Завдання: Розробити алгоритм управління трьома 

виконавчими механізмами (нагрівачем, зволожувачем, 

вентилятором), який був би реалізований у вигляді системи нечіткого 

виведення і дозволяв би генерувати команди управління. 

В якості вхідних параметрів системи нечіткого виведення 

розглядати 2 нечіткі лінгвістичні змінні: «рівень температури» і 

«рівень вологості», а в якості вихідних параметрів - 3 нечіткі 

лінгвістичні змінні «продуктивність нагрівача», «продуктивність 

зволожувача» і «продуктивність вентилятора». 

Як терм-множини для лінгвістичних змінних використовувати 

безліч Ti = {«низький», «середній», «високий»}. При цьому кожен з 

термів першої вхідної змінної оцінювати за шкалою -10 - + 50°С, 

другий вхідний змінної 0 - 100%. Роботу виконавчих механізмів, 

відповідних термам вихідної змінної, припускати можливу в трьох 

режимах: максимальної, середньої потужності і вимкненому. 

Порядок виконання: 

1. Викличте редактор систем нечіткого виводу FIS, для чого у 

вікні команд наберіть ім'я відповідної функції fuzzy. Після виконання 

цієї команди на екрані з'явиться графічний інтерфейс редактора FIS з 

ім'ям системи нечіткого виведення Untitled і типом системи нечіткого 

виведення (Мамдані), запропонованими за замовчуванням (див. Рис. 

1.1). 

2. Оскільки в завданні розглядається система нечіткого 

виведення з двома входами, необхідно додати в розроблену систему 

FIS ще одну вхідну змінну і дві вихідні. Для цього слід виконати 

команду меню Edit> Add Variable ...> Input і Edit> Add Variable ...> 

Output відповідно. 

В результаті виконання цієї команди на діаграмі системи 

нечіткого виведення з'явиться новий жовтий прямокутник з ім'ям 

другої вхідної змінної: input2 і ще два прямокутника вихідних 

змінних: output2, output3 (рис. 1.2). 

3. Змініть імена вхідних і вихідних змінних, запропоновані 

системою MATLAB за замовчуванням. Для цього необхідно виділити 

прямокутник з ім'ям відповідної змінної, виконавши клацання на його 

зображенні на діаграмі (сторони виділеного прямокутника мають 

червоний колір). 
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Після чого слід набрати нове ім'я змінної в поле введення Name 

в правій частині редактора FIS. Результат зміни імен змінних системи 

нечіткого виведення зображений на рис. 1.3. 

Примітка: 

Щоб уникнути проблем з коректним відображенням символів 

кирилиці, слід давати такі імена змінним, які складаються з одного 

слова без додаткових службових символів. 

 

 
Рис. 1.1. Графічний інтерфейс редактора FIS, що викликається 

функцією fuzzy 

 
Рис. 1.2. Вид редактора FIS після додавання другої вхідної змінної 
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Рис. 1.3. Вид редактора FIS після зміни імен змінних, запропонованих 

системою MATLAB за замовчуванням 

 

4. Змініть ім'я системи нечіткого виведення (Untitled), 

запропоноване за замовчуванням. Для цього необхідно зберегти 

створювану структуру FIS в зовнішньому файлі з ім'ям lab1.fis, 

виконавши команду меню File> Export> To Disk .... При цьому буде 

викликано стандартне діалогове вікно збереження файлу, в якому 

користувачеві пропонується ввести ім'я відповідного файлу 

(розширення файлу приписується автоматично). Залиште без зміни 

запропоновані системою MATLAB за замовчуванням: метод 

нечіткого логічного І (And method) - значення «min», метод нечіткого 

логічного АБО (Or method) - значення «max», метод імплікації 

(Implication) - значення «min», метод агрегування (Aggregation) - 

значення «max» і метод дефаззифікації (Defuzzification) - значення 

"centroid». Очевидно, що ці значення можуть бути змінені 

користувачем. 

5. Визначте терми і їх функції приналежності для вхідних і 

вихідних змінних вашої системи нечіткого виведення. Для цього 

ланцюга слід скористатися редактором функцій приналежності, який 

може бути викликаний одним із таких способів: 

- подвійним клацанням на значку прямокутника з ім'ям 

відповідної змінної; 

- командою Edit.Membership Functions ... (попередньо повинен 

бути виділений прямокутник з ім'ям відповідної змінної); 

- натисканням клавіш <Ctrl> + <2> (попередньо повинен бути 

виділений прямокутник з ім'ям відповідної змінної). 

Після виклику редактора функцій належності кожної із змінних 
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за замовчуванням пропонується 3 терма з трикутними функціями 

належності (рис. 1.4). 

 

 
Рис. 1.4. Вид редактора функцій належності після його виклику з 

функціями належності для термів вхідних змінних 

 

Спочатку слід змінити діапазон визначення значень вхідних 

змінних в полях введення Range і Display Range. Аналогічно 

виконайте зміни відповідних діапазонів для вихідних змінних. Зміни 

підтверджуються натисканням на клавішу <Enter> на клавіатурі. 

Далі необхідно змінити назви термів першої з вхідних змінних, 

запропоновані системою MATLAB за замовчуванням (mf1, mf2, mf3) 

на «низький», «середній», «високий» відповідно. Змініть тип функцій 

приналежності змінної, запропонований за умовчанням, на інший тип 

можна, вибравши відповідний пункт в полі Type. Параметри знову 

заданих функцій приналежності залиште без зміни. Вид редактора 

функцій після внесених змін для вхідних змінних зображений на рис. 

1.4. 

Нарешті, змініть назви термів і параметри функцій 

приналежності для вихідних змінних, залишивши без зміни 

трикутний тип функцій приналежності, запропонований системою 

MATLAB. Вид редактора функцій належності після зроблених змін 

для вихідної змінної «нагрівач» зображений на рис. 1.5. 

6. Визначте правила нечіткого виведення для розроблюваної 

експертної системи. Для цієї мети слід скористатися редактором 

правил, який може бути викликаний одним із таких способів: 

- подвійним клацанням на значку квадрата в центрі з ім'ям 

створюваної системи нечіткого виведення (myfis); 

- командою меню Edit> Rules ...; - натисканням клавіш <Ctrl> + 

<3>. 

Оскільки спочатку база правил нечіткого виведення порожня, 

то після виклику редактора правил центральне многострочное поле 

введення не містить ніяких правил. Для їх визначення слід 

використовувати поля меню і перемикачі в нижній частині 

графічного інтерфейсу редактора правил. Виділіть терми вхідних і 
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вихідних змінних, які буде пов'язувати правило. Далі слід перемикач 

Connection поставити в положення and (логічне І) і натиснути на 

кнопку Add rule. Після цього перше правило з символами кирилиці 

відображається у верхньому вікні. Аналогічним чином задаються 

інші правила. 

 

 
Рис. 1.5. Вид редактора функцій належності після зміни назви термів і 

типу їх функцій приналежності для вихідної змінної «нагрівач» 

 

Емпіричні знання по даній проблемній області можуть бути 

представлені у формі наступних евристичних правил продукції: 

1) Якщо температура низька, то нагрівач включити на 

максимальну потужність; 

2) Якщо температура висока, то нагрівач вимкнути; 

3) Якщо вологість низька, то зволожувач включити на 

максимальну потужність; 

4) Якщо вологість висока, то зволожувач вимкнути; 

5) Якщо температура низька і вологість низька, то вентилятор 

вимкнути; 

6) Якщо температура середня, то нагрівач включити на середню 

потужність; 

7) Якщо вологість середня, то зволожувач включити на 

середню потужність; 

8) Якщо температура висока і вологість середня, то включити 

вентилятор на середню потужність; 

9) Якщо температура середня і вологість висока, то включити 

вентилятор на середню потужність; 

10) Якщо температура висока і вологість висока, то включити 

вентилятор на максимальну потужність. 
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Вид редактора правил після їх визначення для розроблюваної 

системи зображений на рис. 1.6. 

В поле введення Weight відображається вага кожного правила, 

який можна змінювати в межах [0, 1] (залиште без зміни його 

значення за замовчуванням, рівне 1 для всіх правил). Цей же вага 

правил записується в круглих дужках у вікні правил після кожного з 

правил нечіткого виводу. 

 

 
Рис. 1.6. Вид редактора правил нечіткого виводу після їх визначення 

 

7. Після завдання правил нечіткого виведення виявляється 

можливим отримати результат нечіткого виведення (значення 

вихідних змінних) для конкретних значень вхідних змінних. З цією 

метою необхідно відкрити програму перегляду правил одним з 

наступних способів: 

- командою меню View> Rules редактора FIS; 

- командою меню View> Rules редактора функцій належності; - 

командою меню View> Rules редактора правил; 

- натисканням клавіш <Ctrl> + <5>. 

Після виклику програми перегляду правил для системи 

нечіткого виведення за замовчуванням для вхідних змінних 

запропоновані середні значення з інтервалу їх допустимих значень 

(рис. 1.7). 

Значення вхідних змінних необхідно змінити для іншого 

випадку, яким відповідають температура і вологість низького рівня. 

Для цього курсор миші слід перемістити в поле вводу Input і ввести 

відповідні значення вхідних змінних. На діаграмі правил можна 

помітити результати виконаних змін (рис. 1.8). 

Оскільки процес нечіткого моделювання передбачає аналіз 
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результатів нечіткого виведення при різних значеннях вхідних 

змінних з метою встановлення адекватності розробленої нечіткої 

моделі, необхідно розглянути й інші випадки. Наприклад, введіть 

значення температури 5°С («низький»), а вологості - 16% 

(«низький»). В цьому випадку розроблена система нечіткого    

виведення рекомендує вам включити нагрівач і зволожувач, а 

вентилятор вимкнути. 

 

 
Рис. 1.7. Вид вікна програми перегляду правил 

 

 
Рис. 1.8. Вид вікна програми перегляду правил 

 

8. Для остаточного аналізу розробленої нечіткої моделі може 

виявитися корисною програма перегляду поверхні нечіткого 

виведення, яка може бути викликана одним із таких способів: 

- командою меню View> Surface редактора FIS; 

- командою меню View> Surface редактора функцій належності; 
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- командою меню View> Surface редактора правил; 

- командою меню View> Surface програми перегляду правил; - 

натисканням клавіш <Ctrl> + <6>. 

Графічний інтерфейс програми перегляду поверхні нечіткого 

виведення для розробленої нечіткої моделі зображений на рис. 1.9. 

 

 
Рис. 1.9. Вид програми перегляду поверхні нечіткого виведення для 

розробленої нечіткої моделі 

 

Ця програма служить для загального аналізу адекватності 

нечіткої моделі, дозволяючи оцінити вплив зміни значень вхідних 

нечітких змінних на значення однієї з вихідних нечітких змінних. У 

разі необхідності можна отримати графік залежності вихідної змінної 

від однієї з вхідних змінних. Для цього необхідно вибрати потрібну 

змінну в списку X (input), а в списку Y (input) вибрати значення -

none-. Отриманий графік залежності, що відповідає середньому 

значенню першої вхідної змінної ( «температура»), зображений на 

рис. 1.10. 

Закінчуючи розгляд процесу розробки найпростішої системи 

нечіткого виведення в інтерактивному режимі, слід зауважити, що 

найбільш ефективним цей спосіб виявляється для складних нечітких 

моделей з великим числом змінних і правил нечіткого виводу. У 

цьому випадку завдання змінних і функцій приналежності з термів в 

графічному режимі, а також візуалізація  правил дозволяють істотно 

зменшити трудомісткість розробки нечіткої моделі, знизити кількість 

можливих помилок і скоротити загальний час нечіткого 

моделювання. 
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Рис. 1.10. Графік залежності першої вихідної змінної від першої з 

вхідних змінних для розробленої нечіткої моделі 

 

У той же час слід пам'ятати, що кількість змінних і правил в 

нечіткої моделі, які можуть бути візуалізовані, обмеженно. Зокрема, 

якщо число вхідних змінних перевищує 10, то їх відображення у 

відповідних графічних редакторах відбувається з спотвореннями. 

Процес розробки системи нечіткого виведення в режимі команд 

може доповнити, а в окремих випадках, і замінити процес розробки в 

інтерактивному режимі, надаючи користувачеві повний контроль над 

усіма змінними робочої області системи MATLAB. 
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Практичне заняття №2 

«Дослідження автоматичної системи з Fuzzy-регулятором» 

 

Мета: Ознайомлення з складом і можливостями 

інструментарію нечіткої логіки та набуття практичних навичок 

роботи в пакеті Fuzzy Logic Toolbox, що входить в пакет програм 

MATLAB. 

Завдання: За допомогою інструментів графічного інтерфейсу 

користувача (GUI) пакета Fuzzy Logic Toolbox створити нечітку 

систему, що реалізовує типовий аналоговий ПІ-регулятор. 

В якості вхідних параметрів системи нечіткого виведення 

розглядати 2 нечіткі лінгвістичні змінні: «x1» і «x2», а в якості 

вихідного параметра - лінгвістичну змінну «y». 

Як терм-множини для лінгвістичних змінних використовувати 

безліч, що складається з семи трикутних непересічних термів Ti = 

{«NB», «NM», «NS», «ZE», «PS», «PM», «PB»}. 

Порядок виконання: 

1. Викличте редактор систем нечіткого виводу FIS, для чого у 

вікні команд наберіть ім'я відповідної функції fuzzy. 

2. Оскільки в завданні розглядається система нечіткого 

виведення з двома входами, необхідно додати в розроблену систему 

FIS ще одну вхідну змінну. Для цього слід виконати команду меню 

Edit> Add Variable ...> Input. 

3. Змініть імена вхідних і вихідних змінних, запропоновані 

системою MATLAB за замовчуванням. 

4. Змініть ім'я системи нечіткого виведення (Untitled), 

запропоноване за замовчуванням. Для цього необхідно зберегти 

створювану структуру FIS в зовнішньому файлі з ім'ям lab2.fis, 

виконавши команду меню File> Export> To Disk .... 

5. Визначте терми і їх функції приналежності для вхідних і 

вихідних змінних вашої системи нечіткого виведення. 

Змініть діапазон визначення значень вхідних змінних в полях 

введення Range і Display Range. Для вхідних змінних регулятора 

рекомендуються симетричні діапазони зміни, при цьому: 
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де k1 і k0 - оптимальні настройки пропорційної і інтегрує 

частин ПІ-регулятора в сенсі будь-якого критерію. 

Налаштування ПІ-регулятора визначаються за формульним 

методом: 
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Параметри об'єкта, в якості моделі якого прийнято аперіодична 

ланка, прийняти з таблиці 2.1. 

 

Таблиця 2.1 - Параметри об'єкта до завдання. 

Варіант 1 2 3 4 5 6 7 8 9 10 11 12 

             

K 1.5 1.8 1.3 1.9 2 2.2 1.4 2.5 2.3 2.4 3.5 3.8 

T 1.8 1.8 1.5 1.5 1.3 1.5 1.5 1.6 1.4 1.7 1.8 1.5 

 

Для вихідної змінної регулятора діапазон зміни рекомендується 

брати в вигляді y[0;C], де верхня межа С при одиничному 

ступінчастому впливі варіюється від 1.1 до 2, щоб вихідний сигнал 

міг компенсувати це обурення. 

У міру збільшення значення С зменшується динамічна 

помилка, але зростають час регулювання і число коливань 

перехідного процесу. Тому рекомендується З приймати рівним 2, 

коли спостерігається оптимальне співвідношення між величиною 

динамічної помилки, часу регулювання і кількістю коливань. 

Далі викличте вікно редактора функцій належності 

(Membership Function Editor) подвійним клацанням миші по 

зображенню змінної або за допомогою меню Edit. Тут для опису 

кожної змінної виберемо сім трикутних термів. Терми вихідної 

змінної краще вибирати непересічними. Це підвищить чіткість 

регулювання. 

Змініть назви термів вхідних і вихідних змінних, запропоновані 

системою MATLAB за замовчуванням (mf1, mf2, mf3, mf4, mf5, mf6, 

mf7) на NB, NM, NS, ZE, PS, PM, PB відповідно. 

6. Визначте правила нечіткого виведення для розроблюваної 

експертної системи. Для вхідних змінних ε(k) і Δε(k) і вихідний Δy(k) 

може бути синтезований fuzzy-регулятор, який реалізує нелінійний 

закон: 

 
)](),([)( kkFky =  

 

і еквівалентний в певному сенсі ПІ-регулятору. 

Для нашого випадку x1 відповідає сигналу неузгодженості ε(k), 

x2 відповідає збільшенню сигналу неузгодженості Δε(k), а y 
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відповідає Δy(k). 

Лінгвістичні правила для такого ПІ-подібного fuzzy-регулятора 

наведені в таблиці 2.2. 

 

Таблиця 2.2 - Лінгвістичні правила для ПІ-подібного fuzzy-

регулятора. 

ε 

Δε 
NB NM NS ZE PS PM PB 

NB NB NB NB NB NM NS ZE 

NM NB NB NB NM NS ZE PS 

NS NB NB NM NS ZE PS PM 

ZE NB NM NS ZE PS PM PB 

PS NM NS ZE PS PM PB PB 

PM NS ZE PS PM PB PB PB 

PB ZE PS PM PB PB PB PB 

 

7. Отримайте результат нечіткого виведення (значення 

вихідних змінних) для конкретних значень вхідних змінних за 

допомогою програми перегляду правил. 

8. Для остаточного аналізу розробленої нечіткої моделі 

викличте програму перегляду поверхні нечіткого виведення. 
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Практичне заняття №3 

«Нечітка модель керування Робокаром» 

 

Мета: Придбання практичних навичок роботи в пакеті Fuzzy 

Logic Toolbox, що входить в пакет програм MATLAB. 

Завдання: За допомогою інструментів графічного інтерфейсу 

користувача (GUI) пакета Fuzzy Logic Toolbox створити нечітку 

систему управління робокар. 

Робокари використовуються для переміщення заготовок, 

предметів незавершеного виробництва і готових деталей. Вони 

переміщаються по замкнутому контуру за допомогою системи 

розпізнавання світловідбивних смуг, нанесених на маршруті 

переміщення. Є можливість отримувати інформацію про швидкість 

руху робокар і дистанції до точки зупинки. Регулювання швидкості 

руху здійснюється за допомогою зміни потужності електродвигуна. 

Важливою проблемою є забезпечення плавної і точної зупинки 

робокар близько пунктів завантаження / розвантаження. 

В якості вхідних параметрів системи нечіткого виведення 

розглядати 2 нечіткі лінгвістичні змінні: відстань від робокар до 

точки зупинки «відстань» і його швидкість «швидкість», а в якості 

вихідного параметра - лінгвістичну змінну «потужність». 

Як терм-множини для лінгвістичної змінної «потужність» 

використовувати безліч, що складається з п'яти трикутних 

непересічних термів Ti = { «NegHigh», «NegMedium», «Zero», 

«PosMedium», «PosHigh»}. 

Кількість термів вхідних змінних задати відповідно до варіанту 

(табл. 3.1). 

При цьому кожен з термів першої вхідної змінної оцінювати за 

шкалою 0 - 10 м, другий вхідний змінної 0 - 3 м/с. Роботу виконавчих 

механізмів, відповідних термам вихідної змінної, припускати 

можливу в межах від -1.5 до +1.5 кВт. 

Таблиця 3.1 - Кількість термів вхідних змінних. 

Варіант 1 2 3 4 5 6 7 8 9 10 11 12 

             

Кількість 

термів 

змінної 

«відстань» 

3 4 5 5 4 5 7 6 6 7 4 3 

Кількість 

термів 

змінної 

«швидкість» 

7 6 5 6 7 4 3 4 5 4 5 6 
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Порядок виконання: 

1. Викличте редактор систем нечіткого виводу FIS, для чого у 

вікні команд наберіть ім'я відповідної функції fuzzy. 

2. Оскільки в завданні розглядається система нечіткого 

виведення з двома входами, необхідно додати в розроблену систему 

FIS ще одну вхідні змінну. Для цього слід виконати команду меню 

Edit> Add Variable ...> Input. 

3. Змініть імена вхідних і вихідних змінних, запропоновані 

системою MATLAB за замовчуванням. 

4. Змініть ім'я системи нечіткого виведення (Untitled), 

запропоноване за замовчуванням. Для цього необхідно зберегти 

створювану структуру FIS в зовнішньому файлі з ім'ям lab3.fis, 

виконавши команду меню File> Export> To Disk .... 

5. Визначте терми і їх функції приналежності для вхідних і 

вихідних змінних вашої системи нечіткого виведення, скориставшись 

редактором функцій приналежності. 

6. Скориставшись редактором правил, визначте правила 

нечіткого виведення для розроблюваної експертної системи. 

7. Отримайте результат нечіткого виведення (значення 

вихідних змінних) для конкретних значень вхідних змінних за 

допомогою програми перегляду правил. 

8. Для остаточного аналізу розробленої нечіткої моделі 

викличте програму перегляду поверхні нечіткого виведення. 
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Практичне заняття №4 

«Нечітка модель керування змішувачем води» 

 

Мета: Придбання практичних навичок роботи в пакеті Fuzzy 

Logic Toolbox, що входить в пакет програм MATLAB. 

Завдання: За допомогою інструментів графічного інтерфейсу 

користувача (GUI) пакета Fuzzy Logic Toolbox створити нечітку 

систему управління змішувачем води при прийнятті душа. 

При прийнятті душа на вхід змішувача подається холодна і 

гаряча вода по відповідним магістральних трубопроводах. Найбільш 

комфортні умови для прийняття душу створюються при наявності на 

виході змішувача теплої води постійної температури. Так як під час 

прийняття душу може спостерігатися нерівномірний витрата води, 

температура води на виході змішувача буде коливатися, приводячи 

до необхідності ручного зміни подачі холодної або гарячої води. 

Завдання полягає в тому, щоб зробити регулювання температури 

води автоматичної, забезпечуючи постійну температуру води на 

виході змішувача. 

В якості вхідних параметрів системи нечіткого виведення 

розглядати 2 нечіткі лінгвістичні змінні: «температура» води і 

«натиск» води, а в якості вихідних параметрів - 2 лінгвістичні змінні: 

кути повороту вентилів гарячої «гаряча» і холодної «холодна» води. 

Як терм-множини для вихідних лінгвістичних змінних 

використовувати безліч, що складається з чотирьох трикутних 

непересічних термів Ti = { «Zero», «Low», «Medium», «High»}. 

Кількість термів вхідних змінних задати відповідно до варіанту 

(табл. 4.1). 

При цьому кожен з термів першої вхідної змінної оцінювати за 

шкалою 0 - 90°С, другий вхідний змінної 0 - 0.5 л/с. Роботу 

виконавчих механізмів, відповідних термам вихідної змінної, 

припускати можливу в межах від 0 - 180° С. 

 

Таблиця 4.1 - Кількість термів вхідних змінних. 

Варіант 1 2 3 4 5 6 7 8 9 10 11 12 

Кількість термів 

змінної 

«температура» 

3 4 5 5 4 5 7 6 6 7 4 3 

Кількість термів 

змінної 

«натиск» 

7 6 5 6 7 4 3 4 5 4 5 6 
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Порядок виконання: 

1. Викличте редактор систем нечіткого виводу FIS, для чого у 

вікні команд наберіть ім'я відповідної функції fuzzy. 

2. Оскільки в завданні розглядається система нечіткого 

виведення з двома входами і двома виходами, необхідно додати в 

розроблену систему FIS ще одну вхідну і одну вихідну змінну. Для 

цього слід виконати команду меню Edit> Add Variable ...> Input і 

Edit> Add Variable ...> Output відповідно. 

3. Змініть імена вхідних і вихідних змінних, запропоновані 

системою MATLAB за замовчуванням. 

4. Змініть ім'я системи нечіткого виведення (Untitled), 

запропоноване за замовчуванням. Для цього необхідно зберегти 

створювану структуру FIS в зовнішньому файлі з ім'ям lab4.fis, 

виконавши команду меню File> Export> To Disk .... 

5. Визначте терми і їх функції приналежності для вхідних і 

вихідних змінних вашої системи нечіткого виведення, скориставшись 

редактором функцій приналежності. 

6. Скориставшись редактором правил, визначте правила 

нечіткого виведення для розроблюваної експертної системи. 

7. Отримайте результат нечіткого виведення (значення 

вихідних змінних) для конкретних значень вхідних змінних за 

допомогою програми перегляду правил. 

8. Для остаточного аналізу розробленої нечіткої моделі 

викличте програму перегляду поверхні нечіткого виведення. 
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Практичне заняття №5 

«Нечітка модель керування системою гальмування автомобіля» 

 

Мета: Придбання практичних навичок роботи в пакеті Fuzzy 

Logic Toolbox, що входить в пакет програм MATLAB. 

Завдання: За допомогою інструментів графічного інтерфейсу 

користувача (GUI) пакета Fuzzy Logic Toolbox створити нечітку 

систему управління системою гальмування автомобілем. 

Об'єкт управління - автомобіль, повинен рухатися досить 

швидко, але при цьому дотримуватися дистанції до автомобіля, що 

їде попереду. 

В якості вхідних параметрів системи нечіткого виведення 

розглядати 3 нечіткі лінгвістичні змінні: «відстань» до найближчого 

автомобіля спереду, «різниця» в швидкостях (між швидкістю 

автомобіля, керованого нечіткої логіки, і швидкістю попереду 

едущегоавтомобіля) і інформація з датчика погоди «погода» (терм-

безліч для цієї змінної складається з чотирьох трикутних термів Ti = { 

«Сухо», «Дощ», «Сніг», «Лід»}). В якості вихідного параметра 

розглядати лінгвістичну змінну «сила гальмування». 

Як терм-множини для вихідної лінгвістичної змінної 

використовувати безліч, що складається з чотирьох трикутних 

непересічних термів Ti = { «Zero», «Low», «Medium», «High»}. 

Кількість термів вхідних змінних «відстань» і «різниця» задати 

відповідно до варіанту (табл. 5.1). 

При цьому кожен з термів першої вхідної змінної оцінювати за 

шкалою 0 - 100 м, другий вхідний змінної -30 - +30 км/год, третій - 

від 0 до 1. Роботу виконавчих механізмів, відповідних термам 

вихідної змінної, припускати можливу в межах від 0 до 100 кН. 

 

Таблиця 5.1 - Кількість термів вхідних змінних. 

Варіант 1 2 3 4 5 6 7 8 9 10 11 12 

Кількість 

термів 

змінної 

«відстань» 

3 5 5 7 4 5 7 3 6 6 4 6 

Кількість 

термів 

змінної 

«різниця» 

7 7 5 5 7 3 3 5 5 7 5 3 
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Порядок виконання: 

1. Викличте редактор систем нечіткого виводу FIS, для чого у 

вікні команд наберіть ім'я відповідної функції fuzzy. 

2. Оскільки в завданні розглядається система нечіткого 

виведення з трьома входами і одним виходом, необхідно додати в 

розроблену систему FIS ще дві вхідні змінні. Для цього слід виконати 

команду меню Edit> Add Variable ...> Input. 

3. Змініть імена вхідних і вихідних змінних, запропоновані 

системою MATLAB за замовчуванням. 

4. Змініть ім'я системи нечіткого виведення (Untitled), 

запропоноване за замовчуванням. Для цього необхідно зберегти 

створювану структуру FIS в зовнішньому файлі з ім'ям lab5.fis, 

виконавши команду меню File> Export> To Disk .... 

5. Визначте терми і їх функції приналежності для вхідних і 

вихідних змінних вашої системи нечіткого виведення, скориставшись 

редактором функцій приналежності. 

6. Скориставшись редактором правил, визначте правила 

нечіткого виведення для розроблюваної експертної системи. 

7. Отримайте результат нечіткого виведення (значення 

вихідних змінних) для конкретних значень вхідних змінних за 

допомогою програми перегляду правил. 

8. Для остаточного аналізу розробленої нечіткої моделі 

викличте програму перегляду поверхні нечіткого виведення. 
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Практичне заняття №6 

«Нечітка модель керування водяними насосами» 

 

Мета: Придбання практичних навичок роботи в пакеті Fuzzy 

Logic Toolbox, що входить в пакет програм MATLAB. 

Завдання: За допомогою інструментів графічного інтерфейсу 

користувача (GUI) пакета Fuzzy Logic Toolbox створити нечітку 

систему управління автоматизованою системою контролю рівня води 

на водовідливної станції. 

Автоматизована система контролю рівня води на водовідливної 

станції складається з трьох підсистем: "Збірна ємність", "Виконавчі 

пристрої" і "Енергопостачання". Підсистема "Збірна ємність" 

представ-ляет собою резервуар, призначений для накопичення 

дощових, ґрунтових, технічних та інших вод. При досягненні певного 

рівня вода перекачується з резервуара в каналізаційну систему. При 

досягненні водою деякого рівня необхідне включення / вимикання 

насосів, які перебувають в підсистемі "Виконавчі пристрої". 

В якості вхідних параметрів системи нечіткого виведення 

розглядати 3 нечіткі лінгвістичні змінні: поточний «рівень води» 

(терм-множина для цієї змінної складається з трьох трикутних термів 

Ti = { «Low», «Medium», «High»}), «тенденція» зміни рівня води і 

«інтенсивність» опадів. В якості вихідного параметра розглядати 

лінгвістичну змінну «пропускна здатність» насосів. 

Як терм-множини для вихідних лінгвістичних змінних 

використовувати безліч, що складається з чотирьох трикутних 

непересічних термів Ti = { «Zero», «Low», «Medium», «High»}. 

Кількість термів вхідних змінних «тенденція» і «інтенсивність» 

задати відповідно до варіанту (табл. 6.1). 

При цьому кожен з термів першої вхідної змінної оцінювати за 

шкалою 0 - 1000 м3, другий вхідний змінної -50 - +50 м3/с, третій - 

від 0 до 80 мм/год. Роботу виконавчих механізмів, відповідних 

термам вихідної змінної, припускати можливу в межах від 0 до 50 

м3/с. 

 

Таблиця 6.1 - Кількість термів вхідних змінних. 

Варіант 1 2 3 4 5 6 7 8 9 10 11 12 

Кількість термів 

змінної 

«інтенсивність» 

3 5 5 7 4 5 7 3 6 6 4 6 

Кількість термів 

змінної 

«тенденція» 

7 7 5 5 7 3 3 5 5 7 5 3 



24 
 

Порядок виконання: 

1. Викличте редактор систем нечіткого виводу FIS, для чого у 

вікні команд наберіть ім'я відповідної функції fuzzy. 

2. Оскільки в завданні розглядається система нечіткого 

виведення з трьома входами і одним виходом, необхідно додати в 

розроблену систему FIS ще дві вхідні змінні. Для цього слід виконати 

команду меню Edit> Add Variable ...> Input. 

3. Змініть імена вхідних і вихідних змінних, запропоновані 

системою MATLAB за замовчуванням. 

4. Змініть ім'я системи нечіткого виведення (Untitled), 

запропоноване за замовчуванням. Для цього необхідно зберегти 

створювану структуру FIS в зовнішньому файлі з ім'ям lab6.fis, 

виконавши команду меню File> Export> To Disk .... 

5. Визначте терми і їх функції приналежності для вхідних і 

вихідних змінних вашої системи нечіткого виведення, скориставшись 

редактором функцій приналежності. 

6. Скориставшись редактором правил, визначте правила 

нечіткого виведення для розроблюваної експертної системи. 

7. Отримайте результат нечіткого виведення (значення 

вихідних змінних) для конкретних значень вхідних змінних за 

допомогою програми перегляду правил. 

8. Для остаточного аналізу розробленої нечіткої моделі 

викличте програму перегляду поверхні нечіткого виведення. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



25 
 

Практичне заняття №7 

«Нечітка модель керування компенсаційною ємністю» 

 

Мета: Придбання практичних навичок роботи в пакеті Fuzzy 

Logic Toolbox, що входить в пакет програм MATLAB. 

Завдання: За допомогою інструментів графічного інтерфейсу 

користувача (GUI) пакета Fuzzy Logic Toolbox створити нечітку 

систему управління компенсаційної ємністю для басейну. 

Приблизний алгоритм управління: 

- максимальний рівень води в компенсаційної ємності включає 

циркуляційний насос; 

- мінімальний рівень води в басейні відкриває електроклапан 

від водопроводу; 

- мінімальний рівень води в компенсаційної ємності відключає 

циркуляційний насос. 

В якості вхідних параметрів системи нечіткого виведення 

розглядати 2 нечіткі лінгвістичні змінні: рівень води в басейні 

«басейн» і рівень води в компенсаційної ємності «ємність», а в якості 

вихідних параметрів - 2 лінгвістичні змінні: «потужність» насоса і 

«кут» відкриття клапана . 

Як терм-множини для вихідних лінгвістичних змінних 

використовувати безліч, що складається з чотирьох трикутних 

непересічних термів Ti = { «Zero», «Low», «Medium», «High»}. 

Кількість термів вхідних змінних задати відповідно до варіанту 

(табл. 7.1). 

При цьому кожен з термів першої вхідної змінної оцінювати за 

шкалою 0 - 40 м3, другий вхідний змінної 0 - 4 м3. Роботу 

виконавчих механізмів, відповідних термам першої вихідної змінної, 

припускати можливу в межах від 0 до 4.5 м3/с, другий - від 0 до 90°С. 

 

Таблиця 7.1 - Кількість термів вхідних змінних. 

Варіант 1 2 3 4 5 6 7 8 9 10 11 12 

Кількість 

термів 

змінної 

«басейн» 

3 4 5 5 4 5 7 6 6 7 4 3 

Кількість 

термів 

змінної 

«ємність» 

7 6 5 6 7 4 3 4 5 4 5 6 
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Порядок виконання: 

1. Викличте редактор систем нечіткого виводу FIS, для чого у 

вікні команд наберіть ім'я відповідної функції fuzzy. 

2. Оскільки в завданні розглядається система нечіткого 

виведення з двома входами і двома виходами, необхідно додати в 

розроблену систему FIS ще одну вхідну і одну вихідну змінну. Для 

цього слід виконати команду меню Edit> Add Variable ...> Input і 

Edit> Add Variable ...> Output відповідно. 

3. Змініть імена вхідних і вихідних змінних, запропоновані 

системою MATLAB за замовчуванням. 

4. Змініть ім'я системи нечіткого виведення (Untitled), 

запропоноване за замовчуванням. Для цього необхідно зберегти 

створювану структуру FIS в зовнішньому файлі з ім'ям lab7.fis, 

виконавши команду меню File> Export> To Disk .... 

5. Визначте терми і їх функції приналежності для вхідних і 

вихідних змінних вашої системи нечіткого виведення, скориставшись 

редактором функцій приналежності. 

6. Скориставшись редактором правил, визначте правила 

нечіткого виведення для розроблюваної експертної системи. 

7. Отримайте результат нечіткого виведення (значення 

вихідних змінних) для конкретних значень вхідних змінних за 

допомогою програми перегляду правил. 

8. Для остаточного аналізу розробленої нечіткої моделі 

викличте програму перегляду поверхні нечіткого виведення. 
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Практичне заняття №8 

«Нечітка модель керування шахтною зерносушаркою» 

 

Мета: Придбання практичних навичок роботи в пакеті Fuzzy 

Logic Toolbox, що входить в пакет програм MATLAB. 

Завдання: За допомогою інструментів графічного інтерфейсу 

користувача (GUI) пакета Fuzzy Logic Toolbox створити нечітку 

систему управління шахтної зерносушаркою. 

Для підтримки заданої вологості за допомогою зміни 

температури повітря, що подається, використовується калорифер, 

керуючий сигнал на який надходить з виходу регулятора 

температури. Потужність калорифера пропорційно пов'язана зі 

зміною температури. 

В якості вхідних параметрів системи нечіткого виведення 

розглядати 2 нечіткі лінгвістичні змінні: «неузгодженість» 

(відхилення від норми) між заданою і поточної вологістю зерна, яка 

вимірюється влагомером, встановленим всередині зерносушарки, і 

перша «похідна» цього неузгодженості, а в якості вихідного 

параметра - лінгвістичну змінну «споживана потужність». 

Як терм-множини для лінгвістичної змінної «споживана 

потужність» використовувати безліч, що складається з п'яти 

трикутних непересічних термів Ti = { «NegHigh», «NegMedium», 

«Zero», «PosMedium», «PosHigh»}. 

Кількість термів вхідних змінних задати відповідно до варіанту 

(табл. 8.1). 

При цьому кожен з термів першої вхідної змінної оцінювати за 

шкалою 0 - 10%, другий вхідний змінної 0 - 0.05 1/с. Роботу 

виконавчих механізмів, відповідних термам вихідної змінної, 

припускати можливу в межах від 0 до 4 кВт. 

 

Таблиця 8.1 - Кількість термів вхідних змінних. 

Варіант 1 2 3 4 5 6 7 8 9 10 11 12 

Кількість термів 

змінної 

«неузгодженість» 

3 4 5 5 4 5 7 6 6 7 4 3 

Кількість термів 

змінної 

«похідна» 

7 6 5 6 7 4 3 4 5 4 5 6 
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Порядок виконання: 

1. Викличте редактор систем нечіткого виводу FIS, для чого у 

вікні команд наберіть ім'я відповідної функції fuzzy. 

2. Оскільки в завданні розглядається система нечіткого 

виведення з двома входами, необхідно додати в розроблену систему 

FIS ще одну вхідні змінну. Для цього слід виконати команду меню 

Edit> Add Variable ...> Input. 

3. Змініть імена вхідних і вихідних змінних, запропоновані 

системою MATLAB за замовчуванням. 

4. Змініть ім'я системи нечіткого виведення (Untitled), 

запропоноване за замовчуванням. Для цього необхідно зберегти 

створювану структуру FIS в зовнішньому файлі з ім'ям lab8.fis, 

виконавши команду меню File> Export> To Disk .... 

5. Визначте терми і їх функції приналежності для вхідних і 

вихідних змінних вашої системи нечіткого виведення, скориставшись 

редактором функцій приналежності. 

6. Скориставшись редактором правил, визначте правила 

нечіткого виведення для розроблюваної експертної системи. 

7. Отримайте результат нечіткого виведення (значення 

вихідних змінних) для конкретних значень вхідних змінних за 

допомогою програми перегляду правил. 

8. Для остаточного аналізу розробленої нечіткої моделі 

викличте програму перегляду поверхні нечіткого виведення. 
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